<!DOCTYPE html><html dir="ltr" lang="en" class="no-js"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>Programming as a Way of Thinking - Scientific American Blog Network</title><script>var A17 = window.A17 || {};A17.svgSupport = document.implementation.hasFeature("http://www.w3.org/TR/SVG11/feature#BasicStructure", "1.1");A17.browserSpec = (typeof document.querySelectorAll && 'addEventListener' in window && A17.svgSupport) ? "html5" : "html4";var element = document.createElement('x');element.style.cssText = 'pointer-events:auto';(function(){var doc = document.documentElement;var str = " js "+(A17.svgSupport ? " svg" : " no-svg") + (element.style.pointerEvents === 'auto' ? " csspointerevents" : " no-csspointerevents");doc.className = doc.className.replace(/\bno-js\b/,str);})();A17.loadCSS = function(href){"use strict";var ss = window.document.createElement( "link" );var ref = window.document.getElementsByTagName( "script" )[ 0 ];var sheets = window.document.styleSheets;ss.rel = "stylesheet";ss.href = href;ss.media = "only x";ref.parentNode.insertBefore( ss, ref );ss.onloadcssdefined = function( cb ){var defined;for( var i = 0; i < sheets.length; i++ ){if( sheets[ i ].href && sheets[ i ].href.indexOf( href ) > -1 ){defined = true;}}if( defined ){cb();} else {setTimeout(function() {ss.onloadcssdefined( cb );});}};ss.onloadcssdefined(function() {ss.media = "all";});return ss;};A17.loadCSS("/public/resources/icons-6bbdbe0c0bc51b6dcb36c6535563b1a6.css");userHasAccessOptimizely = false;</script><link rel="apple-touch-icon-precomposed" sizes="196x196" href="/public/resources/favicons/favicon-196-73208969ab1ed3409bc55e8915ed8bae.png"/><link rel="apple-touch-icon-precomposed" sizes="128x128" href="/public/resources/favicons/favicon-128-c8f859d1014234520d7e542de84686de.png"/><link rel="apple-touch-icon-precomposed" sizes="96x96" href="/public/resources/favicons/favicon-96-dba133e71973e661bb307c3aeb34eef3.png"/><link rel="apple-touch-icon-precomposed" sizes="32x32" href="/public/resources/favicons/favicon-32-98279223f56790c51fe10cdd69903dcc.png"/><link rel="apple-touch-icon-precomposed" sizes="16x16" href="/public/resources/favicons/favicon-16-5e90814f8e355cae989b4f7a0b95829a.png"/><link rel="shortcut icon" href="/public/resources/favicons/favicon-2bdc20b6b8b461ae319099c48d4f62d0.ico"/><link rel="logo" type="image/svg" href="/resources/source/icon__logo--lg.svg"/><meta name="msapplication-TileImage" content="/public/resources/favicons/favicon-196-73208969ab1ed3409bc55e8915ed8bae.png"><meta name="referrer" content="always"><link rel="stylesheet" type="text/css" href="/public/resources/sa-22205f27a2668bc48ea2e52bf0d2a41f.css"/>
<script type="text/javascript" src="/sciam/includes/themes/responsive/js/mura.min.js?v=1"></script>
	<script type="text/javascript">
	Mura.init({
		loginURL:"?display=login",
		siteid:"blogs",
		contentid:"07616940-7010-46B9-B4F730530E741A16",
		contenthistid:"6547259F-79F5-41F4-AB2C662797CFA768",
		type:"Page",
		subtype:"BlogPost",
		ismind:"false",
		siteID:"blogs",
		context:"",
		jslib:"jquery",
		nocache:0,
		assetpath:"/sciam",
		siteConfig:"/requirements",
		themepath:"/sciam/includes/themes/responsive",
		rb:"en",
		reCAPTCHALanguage:"en",
		preloaderMarkup: "",
		mobileformat: "false",
		adminpreview: "false",
		windowdocumentdomain: "",
		dtExample:"11/10/2018",
	dtCh:"/",
	dtFormat:[0,1,2],
	dtLocale:"en-US"
	});
</script>
<meta property="og:site_name" content="Scientific American Blog Network"/>
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Programming as a Way of Thinking" />
	<meta property="og:description" content="The power of modern programming languages is that they are expressive, readable, concise, precise, and executable" />
	<meta property="og:image" content="https://blogs.scientificamerican.com/blogs/cache/file/3165F741-DE77-47EF-A91AEDFD7E2F0CCA_agenda.jpg?w=600&amp;h=335" />
	<meta property="og:url" content="https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/" />

	
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:site" content="@sciam">
	<meta name="twitter:title" content="Programming as a Way of Thinking">


	
	
		<meta name="author" content="Allen Downey" />
	
	
	<meta name="parsely-metadata" content='{"contentid": "07616940-7010-46B9-B4F730530E741A16"}'>
	<meta name="description" content="The power of modern programming languages is that they are expressive, readable, concise, precise, and executable">
	<meta name="keywords" content="">
<!-- BEGIN Krux ControlTag for "Scientific American" -->
<script class="kxct" data-id="Jn7TXKj3" data-timing="async" data-version="3.0" type="text/javascript">
 window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
 (function(){
 var k=document.createElement('script');k.type='text/javascript';k.async=true;
 k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/Jn7TXKj3.js';
 var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
 }());
</script>
<!-- END Krux ControlTag -->
	

<!-- BEGIN KRUX INTERCHANGE GPT -->
<script>
	window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]); (function(){
	function retrieve(n){
	var m, k='kx'+n;
	if (window.localStorage) {
	return window.localStorage[k] || "";
	} else if (navigator.cookieEnabled) {
	m = document.cookie.match(k+'=([^;]*)'); return (m && unescape(m[1])) || "";
	 } else {
	 return '';
	} }
	Krux.user = retrieve('user');
	Krux.segments = retrieve('segs') && retrieve('segs').split(',') || [];
	})();
</script>
<!-- END KRUX INTERCHANGE GPT -->


<!-- BEGIN KRUX INTERCHANGE DFP LEGACY -->
<script class="kxint" type="text/javascript">
 window.Krux || ((Krux = function() {
 Krux.q.push(arguments);
 }).q = []);
 (function() {
 function retrieve(n) {
 var m, k = 'kx' + n;
 if (window.localStorage) {
 return window.localStorage[k] || "";
 } else if (navigator.cookieEnabled) {
 m = document.cookie.match(k + '=([^;]*)');
 return (m && unescape(m[1])) || "";
 } else {
 return '';
 }
 }
 Krux.user = retrieve('user');
 Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : []; 
 var dfpp = [];
 if (Krux.user) {
 dfpp.push('kuid=' + Krux.user);
 }
 for (var i = 0; i < Krux.segments.length; i++) {
 dfpp.push('ksg=' + Krux.segments[i]);
 }
 Krux.dfppKeyValues = dfpp.length ? dfpp.join(';') + ';' : '';
 })();
</script>
<!-- END KRUX INTERCHANGE DFP LEGACY -->

<!-- Start: GPT Async -->
<script type='text/javascript'>
	 var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') +
		 '//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
	})();
</script>



<script type="text/javascript">
// PubNation
window._pnq = window._pnq || [];
_pnq.push(['setId', 'pn-d2de07196d68657e']);
(function() {
 var pnr = document.createElement('script');
 pnr.type = 'text/javascript';
 pnr.async = true;
 pnr.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'report-ads-to.pubnation.com/dist/pnr.js?t=pn-d2de07196d68657e';
 var s = document.getElementsByTagName('script')[0];
 s.parentNode.insertBefore(pnr, s);
})();
 
dfp = {};

dfp.targeting = {"primary-cat":"computing","topic":["tech","computing"],"ref-url":"https://rails-rn-prod.sandia.gov/plug/articles/11860","type":"blog","author":"allen downey","title":"programming as a way of thinking","tags":"","section":"guest blog"};


function get_screen_size(screenWidth) {
	if (screenWidth > 1023) {
		return "desktop";
	}
	else if (screenWidth <= 1023 && screenWidth > 767) {
		return "tablet";
	}
	else {
		return "mobile";
	}
}

// refresh Ads on screen resize
dfp.screen_size = get_screen_size(window.innerWidth);
dfp.targeting['screen_size'] = dfp.screen_size;

window.addEventListener("resize", function(){
	var newSize = get_screen_size(window.innerWidth);
	if (newSize != dfp.screen_size) {
		dfp.screen_size = newSize;
		googletag.cmd.push(function() {
			googletag.pubads().refresh();
		});
	}
});


var gptadslots=[];
dfp.adUnit = "/67238587/sciam.com/blogs/guest-blog";
dfp.adslots = {};

dfp.top = {
	sizes : "[320, 50]",
	name: "div-gpt-ad-top-",
	count : 0
};

dfp.middle = {
	sizes : "[320, 50]",
	name: "div-gpt-ad-middle1-",
	count : 0
};

dfp.right = {
	sizes : "[300, 250]",
	name: "div-gpt-ad-right1-",
	count : 0
};

dfp.right2 = {
	sizes : "[300, 250]",
	name: "div-gpt-ad-right2-",
	count : 0
};

dfp.slideshow = {
	sizes : "[300, 250]",
	name: "div-gpt-ad-slideshow-",
	count : 0
};


googletag.cmd.push(function() {
	dfp.top.mapping = googletag.sizeMapping().
		addSize([1, 1 ], [320, 50]).
		addSize([767, 1 ], [728, 90]).
		addSize([1023, 1 ], [[728, 90], [970, 90]]).
		build();

	dfp.middle.mapping = googletag.sizeMapping().
		addSize([1, 1 ], [320, 50]).
		addSize([767, 1 ], [728, 90]).
		addSize([1023, 1 ], [[728, 90], [970, 90], [970, 250]]).
		build();

	dfp.right.mapping = googletag.sizeMapping().
		addSize([1023, 1 ], [[300, 250], [300, 600]]).
		addSize([767, 1 ], [[300, 250], [300, 600]]).
		addSize([1, 1 ], [300, 250]).
		build();

	dfp.right2.mapping = googletag.sizeMapping().
		addSize([1023, 1 ], [300, 250]).
		addSize([767, 1 ], [300, 250]).
		addSize([1, 1 ], [300, 250]).
		build();

	dfp.slideshow.mapping = googletag.sizeMapping().
		addSize([1023, 1 ], [300, 250]).
		addSize([767, 1 ], [300, 250]).
		addSize([1, 1 ], [300, 250]).
		build();
	
	gptadslots[0] = googletag.defineSlot('/67238587/sciam.com/blogs/guest-blog', [300, 50], 'div-gpt-ad-top-1').defineSizeMapping(dfp.top.mapping).setTargeting('position',['top']).addService(googletag.pubads());

	gptadslots[1] = googletag.defineOutOfPageSlot('/67238587/sciam.com/blogs/guest-blog', 'div-gpt-ad-interstitial-1').addService(googletag.pubads());


	// All page-level DFP Custom Tagging goes here
	googletag.pubads()
		.setTargeting('section', dfp.targeting['section'])
		.setTargeting('type', dfp.targeting['mediatype'])
		.setTargeting('primary-cat', dfp.targeting['primary-cat'])
		.setTargeting('topic', dfp.targeting['topic'])
		.setTargeting('title', dfp.targeting['title'])
		.setTargeting('tags', dfp.targeting['tags'])
		.setTargeting('author', dfp.targeting['author'])
		
		.setTargeting('device', dfp.screen_size)
		.setTargeting('ref-url', dfp.targeting['ref-url']);

	googletag.pubads().setTargeting("ksg", Krux.segments);
	googletag.pubads().setTargeting("kuid", Krux.user);
	
	googletag.pubads().enableSingleRequest();
	googletag.pubads().enableAsyncRendering();
	googletag.enableServices();
});
</script>

<!-- End: GPT -->


<script type="text/javascript">
dfp.load_dfp_ad = function(adName, positionName, adContainer, adOffset) {
	var isAdActive = false;

	if (adOffset === undefined || !adOffset.length) {
		adOffset = document.getElementById(adContainer).offsetTop-500;
	}

	window.addEventListener('scroll', function() {
		var pageOffset = window.pageYOffset;

		if((pageOffset > adOffset) && !isAdActive) {
			isAdActive = true;

			dfp[adName].count++;
			var slotName = dfp[adName].name + dfp[adName].count;

			var adSlotDiv = document.createElement('div');
 			adSlotDiv.id = slotName;
 			document.getElementById(adContainer).appendChild(adSlotDiv);

 			if (positionName == "") {
 				positionName = adName+dfp[adName].count;
 			}
			
			googletag.cmd.push(function() {
				gptadslots.push( googletag.defineSlot(dfp.adUnit, dfp[adName].sizes, slotName).
				defineSizeMapping(dfp[adName].mapping).
				setTargeting('position',[positionName]).
				addService(googletag.pubads()) );

				dfp.adslots[positionName] = googletag.display(slotName);
				//googletag.pubads().refresh([slot]);
			});

			//PubNation
			window._pnq.push(['addListeners']);
		}
	});
};

</script>
<!--script src="//cdn.optimizely.com/js/2007700279.js"></script--><!--[ if lte IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"> </script><![ endif]--></head><body class="site-blogs lang-en  leaderboard-top"><script>dataLayer = [{"content":{"authorization":{"status":1,"freeToAccess":1,"type":"free_to_air"},"category":{"contentSubType1":"Guest Blog","subjectSubType1":"Computing","subjectType":"Tech","contentType":"BlogPost"},"updatedAt":"","contentInfo":{"contentId":"07616940-7010-46B9-B4F730530E741A16","brand":"Scientific American","publishedAt":1493204400,"author":["Allen Downey"],"title":"Programming as a Way of Thinking"},"attributes":{"language":"en","wordCount":728,"copyright":{"native":0,"syndicated":1,"resale":0}}},"session":{"createdAt":"","authentication":{"loginStatus":"logged out"},"updatedAt":"","attributes":{},"sessionInfo":{"sessionID":"{{GA populated session ID}}"}},"version":"1.0.0","product":[],"privacy":{},"user":[{"licence":[{"category":{"licenceType":""},"licenceInfo":{"licenceName":"","licenceID":""},"attributes":{}}],"updatedAt":"","segment":{"emailSubscriber":0,"appUserMind":0,"registered":0,"customer":0,"subscriberMind":0,"appUserSA":0,"subscriber":0,"giftRecipient":0,"commented":0,"subscriberSA":0},"profile":[{"profileInfo":{"profileID":""},"attributes":{"recency":{"appLoginSA":"","appLoginMind":"","webLogin":""}}}]}],"page":{"error":{},"pageInfo":{},"category":{"pageType":"single-page"},"attributes":{},"component":[{}]}}];</script><div id='div-gpt-ad-interstitial-1' class="banner-interstitial"><script type='text/javascript'>googletag.cmd.push(function() {googletag.display("div-gpt-ad-interstitial-1");});</script></div><!--[if IE 8]><![endif]--><!--[if lte IE 9]><div class="browser-update" data-behavior="browser_update"><div class="container"><p class="t_meta"><span class="browser-update__alert"><img src="/public/resources/png/icon__alert-a313300df9de48356a7faee7f3be54f5.png" alt=""></span> We're sorry, your browser is not supported. Please update to a modern browser to view this page. <a href="https://www.scientificamerican.com/page/frequently-asked-questions/?tab=about-the-site#what-are-the-technical-specifications-for-using-scientificamericancom" class="browser-update__link">Learn More</a></p><div class="browser-update__close"><a href="#" data-browser-update-close><span class="icon icon__close--black icon--subtle"></span></a></div></div></div><![endif]--><div class="browser-update--hide" data-behavior="browser_update" id="cookie-policy"><div class="container"><p class="t_meta">We use cookies to provide you with a better onsite experience. By continuing to browse the site you are agreeing to our use of cookies in accordance with our <a class='browser-update__link' href='http://www.scientificamerican.com/page/use-of-cookies/' target='_blank'>Cookie Policy</a>.</p><div class="browser-update__close"><a href="#" data-browser-update-close><span class="icon icon__close--black icon--subtle" data-behavior="cookie_policy" id="cookie_policy_close"></span></a></div></div></div><a class="skipnav" href="#sa_body">Skip to main content</a><div id="scientific-american"><div class="banner banner-leaderboard banner-leaderboard-top" data-banner-leaderboard><div id="div-gpt-ad-top-1"><script>googletag.cmd.push(function() {googletag.display("div-gpt-ad-top-1");});</script></div></div><div class="sticky-bounds" data-sticky-bounds data-sticky-id="site-header"><div class="sticky-header" data-sticky-container data-sticky-id="site-header"><div id="site-header" class="sticky-header__inner" data-behavior="sticky subscribe_hover"><div class="header-outer container"><header class="header"><div class="header__left"><a href="https://www.scientificamerican.com/store/subscribe/scientific-american-magazine/?WT.ac=SA_ecom_SA_Nav_Subscribe_white" id="subscribe-nav-btn" class="btn--small header__left__subscribe-btn">Subscribe</a><a class="header__menu-link" data-behavior="click_trigger" data-event-name="primary_nav:open" href="#"><span class="header__left__menu-btn icon icon__menu--black">Menu</span></a></div><div class="header__logo header__logo--en"><a href="https://www.scientificamerican.com/" class="icon icon__logo--lg header__logo__icon">Scientific American</a></div><div class="header__right tooltip-outer"><ul class="header__right__utils meta-list"><li class="meta-list__item tx_meta link" data-tooltip-trigger data-tooltip="region-tooltip">English <a href="#" class="icon icon--after icon--subtle icon__ddarr--black" data-behavior="tooltip" data-tooltip-width="180" data-tooltip-id="region-tooltip"></a></li><li class="meta-list__item tx_meta"><a class="link" href="https://www.scientificamerican.com/store/shopping-cart/">Cart <span class="cart-count">0</span></a></li><li class="meta-list__item tx_meta" data-behavior="sign_in_flyout"><a class="link signin-click" id="signin-click">Sign In</a>&nbsp;&nbsp;|&nbsp;&nbsp; <a href="https://www.scientificamerican.com/my-account/register/" class="link register-click">Register</a><section class="signin-flyout" id="signin-flyout"><span class="icon icon__close--white" id="signin-flyout__close"></span><span class="signin-flyout__arrow"></span><form class="signin-flyout__form" action="https://www.scientificamerican.com/my-account/login/?s=1" method="post"><input type="hidden" name="slatAction" value="public:account.login" /><input type="hidden" name="flyoutlogin" value="true" /><input type="hidden" name="csrf_token" value="2439FC2ABE8CA8CE9C3310534B39ED44" />
				<input type="hidden" name="csrf_token_expires" value="170502145045568" /><label for="emailAddress1" class="signin-flyout__form__label">Email:</label><input type="textbox" name="emailAddress" id="emailAddress1" class="signin-flyout__form__input" data-signin-email/><label for="password1" class="signin-flyout__form__label">Password:</label><input type="password" name="password" id="password1" class="signin-flyout__form__input" data-signin-password/><a href="https://www.scientificamerican.com/my-account/forgot-password/" class="signin-flyout__form__forgot">Forgot password?</a><button class="btn btn--small btn--inverted signin-flyout__form__submit"  type="submit" data-signin-submit-btn>Login</button><img src="/public/resources/loader-824962d9e67c8497c9ef428a9fdfad71.gif" class="signin-flyout__form__loading" alt="Loading" data-signin-loading/></form><a href="https://www.scientificamerican.com/my-account/register/" class="signin-flyout__register">Not yet registered?</a></section></li></ul><button class="header__right__search-btn"><span class="icon icon__search--black" data-mobile-search-btn>Search</span></button><a class="header__right__subscribe" href="https://www.scientificamerican.com/store/subscribe/scientific-american-magazine/?WT.ac=SA_ecom_SA_Nav-Subscribe-mobile">Subscribe</a><div class="tooltip tooltip--dark" id="region-tooltip"><span class="tooltip__arrow"></span><div class="account-tooltip"><ul class="account-tooltip__list"><li><a href="https://www.scientificamerican.com/">English</a></li><li><a href="https://www.scientificamerican.com/espanol/">Español</a></li><li><a href="https://www.scientificamerican.com/arabic/">العربية</a></li><li><a href="https://www.scientificamerican.com/page/international/">Other Editions</a></li></ul></div></div></div></header><div class="mobile-search" data-behavior="mobile_search"><form data-mobile-search-form method="GET" action="https://www.scientificamerican.com/search/"><div class="mobile-search__input-container"><label class="hide-label" for="mobile-search-input">Search</label><input class="mobile-search__input" placeholder="Search" data-mobile-search-input type="text" id="mobile-sidebar-search" data-behavior="search" name="q" /><button type="submit" class="mobile-search__icon icon icon__search--white"></button><span data-mobile-search-close class="mobile-search__icon mobile-search__icon--close icon icon__close--white"></span></div></form><ul class="mobile-search__results" data-mobile-search-results id="mobile-search-results"></ul></div><aside class="subscribe-sidebar" data-subscribe-hover-panel><!--div class="subscribe-sidebar__cover mura-async-object" data-object="current-issue" data-ismind="0" data-instanceid="0" data-contentid="00000000000000000000000000000000001" data-contenthistid=""></div--></aside></div><nav class="primary-nav" data-behavior="primary_nav"><div class="primary-nav__bg"></div> <!-- bg opacity layer --><div class="primary-nav__container container"> <!-- close button for burger menu --><button class="primary-nav__close-btn"><span class="icon icon--subtle icon__close--white">Close</span></button></div><div class="primary-nav__inner" id="primary-nav__inner" data-primary-nav><div class="primary-nav__inner__container container"><div class="primary-nav__search-container"><form id="search-form" action="https://www.scientificamerican.com/search/" method="GET"><label for="sidebar-search" class="hide-label">Search</label><div class="primary-nav__search-bar"><input id="sidebar-search" type="text" name="q" placeholder="Search" class="primary-nav__search-input" data-behavior="search"/></div><button type="submit" class="primary-nav__search-btn icon icon__search--black"></button></form></div><div class="primary-nav__search-results"><div class="primary-nav__search-results__inner"><div class="search-results"><ul class="search-results__inner" id="search-results"></ul></div></div></div><ul class="primary-nav__list" data-behavior="child_navs"><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/the-sciences/">The Sciences</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/mind/" >Mind</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/health/" >Health</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/tech/" > Tech</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/sustainability/" >Sustainability</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/education/">Education</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/video/">Video</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/podcasts/">Podcasts</a></li><li class="primary-nav__list__item"><a href="https://blogs.scientificamerican.com/">Blogs</a></li><li class="primary-nav__list__item"><a href="https://www.scientificamerican.com/store/">Store</a></li></ul><div class="primary-nav__drawer-utils"><a href="https://www.scientificamerican.com/store/subscribe/scientific-american-magazine/?WT.ac=SA_ecom_SA_Nav_Subscribe_white" class="btn btn--small">Subscribe</a><a href="https://www.scientificamerican.com/magazine/sa/2017/05-01/" class="btn btn--small">Current Issue</a><ul class="primary-nav__drawer-utils__list" data-behavior="child_navs"><li class="primary-nav__drawer-utils__list__item"><a href="https://www.scientificamerican.com/store/shopping-cart/">Cart</a></li><li class="primary-nav__drawer-utils__list__item"><a href="https://www.scientificamerican.com/my-account/login/">Sign In</a></li><li class="primary-nav__drawer-utils__list__item"><a href="https://www.scientificamerican.com/my-account/register/">Register</a></li></ul><ul class="primary-nav__drawer-utils__social"></ul></div></div></div>	</nav></div></div><main id="sa_body" class="panel main-area"><div class="mura-region"><div class="mura-region-inherited"></div><div class="mura-region-local"></div></div><header class="article-header no-main-area-space container"><div class="article-header__inner"><div class="article-header__inner__blog-category"><a href="/guest-blog/"><span class="article-header__inner__blog-category__icon"><img src="/blogs/cache/file/6B1D723C-1082-4207-9FA9D89EA23647C1_small.jpg?h=45&w=45" alt="Guest Blog" /></span><span class="article-header__inner__blog-category__label">Guest Blog</span></a></div><h1 class="article-header__title t_article-title">Programming as a Way of Thinking</h1><p class="t_article-subtitle">The power of modern programming languages is that they are expressive, readable, concise, precise, and executable</p><div class="article-header__divider"><ul class="meta-list t_meta"><li class="meta-list__item">By <a href="https://www.scientificamerican.com/author/allen-downey/">Allen Downey</a> on April 26, 2017 </li></ul></div></div></header><div class="article-progress" data-behavior="article_progress"><div class="article-progress__bar"></div><div class="article-grid-outer container"><div class="article-grid"><aside class="article-grid__share"><div class="share-box tooltip-outer"><div style="overflow: hidden"><ul class="share-box__inner"><li class="share-box__inner__item"><a href="#" data-sharer-url="http://www.facebook.com/sharer/sharer.php?p[url]=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/?wt.mc=SA_Facebook-Share" class="share-box__inner__item__link" data-social-provider="Facebook" data-behavior="sharer tooltip" data-tooltip-hover data-tooltip-top data-tooltip-width="225" data-tooltip-id="facebook-tooltip"><span class="icon icon__facebook--black"></span></a></li><li class="share-box__inner__item"><a href="#" class="share-box__inner__item__link" data-social-provider="Twitter" data-behavior="sharer tooltip" data-sharer-url="https://twitter.com/intent/tweet?url=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/?wt.mc=SA_Twitter-Share&amp;text=Programming as a Way of Thinking&amp;hashtags=science" data-tooltip-hover data-tooltip-top data-tooltip-width="208" data-tooltip-id="twitter-tooltip"><span class="icon icon__twitter--black"></span></a></li><li class="share-box__inner__item"><a href="#" class="share-box__inner__item__link" data-social-provider="Reddit" data-behavior="sharer tooltip" data-sharer-url="http://www.reddit.com/submit?url=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/%3Fwt.mc=SA_Reddit-Share" data-tooltip-hover data-tooltip-top data-tooltip-width="208" data-tooltip-id="reddit-tooltip"><span class="icon icon__reddit--black"></span></a></li><li class="share-box__inner__item"><a href="#" class="share-box__inner__item__link" data-social-provider="Share" data-behavior="tooltip" data-tooltip-top data-tooltip-width="150" data-tooltip-id="share-tooltip"><span class="icon icon__share--black"></span></a></li><li class="share-box__inner__item"><a href="https://blogs.scientificamerican.com/email-this-article/?contentid=07616940-7010-46B9-B4F730530E741A16" data-social-provider="Email" class="share-box__inner__item__link" data-behavior="tooltip" data-tooltip-hover data-tooltip-top data-tooltip-width="141" data-tooltip-id="email-tooltip"><span class="icon icon__mail--black"></span></a></li><li class="share-box__inner__item"><a href="?print=true" class="share-box__inner__item__link" data-social-provider="Print" data-behavior="tooltip" data-tooltip-hover data-tooltip-top data-tooltip-width="111" data-tooltip-id="print-tooltip"><span class="icon icon__print--black"></span></a></li></ul></div><div class="tooltip tooltip--dark tooltip--thin tooltip--top" style="width: 225px;" id="facebook-tooltip"><span class="tooltip--top__arrow tooltip__arrow"></span><div class="share-tooltip share-tooltip--thin"><div class="share-tooltip__label">Share on Facebook<!--div class="share-tooltip__label__count" data-share-count-facebook></div--></div></div></div><div class="tooltip tooltip--dark tooltip--thin tooltip--top" style="width: 208px;" id="twitter-tooltip"><span class="tooltip--top__arrow tooltip__arrow"></span><div class="share-tooltip share-tooltip--thin"><div class="share-tooltip__label">Share on Twitter<!---div class="share-tooltip__label__count" data-share-count-twitter></div---></div></div></div><div class="tooltip tooltip--dark tooltip--thin tooltip--top" style="width: 208px;" id="reddit-tooltip"><span class="tooltip--top__arrow tooltip__arrow"></span><div class="share-tooltip share-tooltip--thin"><div class="share-tooltip__label">Share on Reddit<!---div class="share-tooltip__label__count" data-share-count-reddit></div---></div></div></div><div class="tooltip tooltip--dark tooltip--thin tooltip--top" style="width: 141px;" id="email-tooltip"><span class="tooltip--top__arrow tooltip__arrow"></span><div class="share-tooltip share-tooltip--thin"><div class="share-tooltip__label">Email</div></div></div><div class="tooltip tooltip--dark tooltip--thin tooltip--top" style="width: 111px;" id="print-tooltip"><span class="tooltip--top__arrow tooltip__arrow"></span><div class="share-tooltip share-tooltip--thin"><div class="share-tooltip__label">Print</div></div></div><div class="tooltip tooltip--dark tooltip--thin tooltip--top" data-keep-tooltip style="width: 150px" id="share-tooltip"><span class="tooltip--top__arrow tooltip__arrow"></span><div class="share-tooltip"><div class="share-tooltip__title">Share via</div><ul class="share-tooltip__list"><li><a href="#" data-social-provider="Google+" data-behavior="sharer" data-sharer-url="https://plus.google.com/share?url=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/?wt.mc=SA_GPlus-Share">Google+</a></li><li><a href="#" data-social-provider="Stumble Upon" data-behavior="sharer" data-sharer-url="http://www.stumbleupon.com/submit?url=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/&amp;title={data.}">Stumble Upon</a></li></ul></div></div></div><div class="mura-region"><div class="mura-region-inherited"></div><div class="mura-region-local"></div></div></aside><section class="article-grid__main"> <figure class="article-media "  ><div class="article-media__object "><picture><source media="(min-width: 768px) and (max-width: 1023px)" srcset="https://blogs.scientificamerican.com/blogs/cache/file/3165F741-DE77-47EF-A91AEDFD7E2F0CCA.jpg?w=690&amp;h=460&amp;6547259F-79F5-41F4-AB2C662797CFA768"><source media="(max-width: 767px)" srcset="https://blogs.scientificamerican.com/blogs/cache/file/3165F741-DE77-47EF-A91AEDFD7E2F0CCA.jpg?w=280&amp;h=187&amp;6547259F-79F5-41F4-AB2C662797CFA768"><img src="https://blogs.scientificamerican.com/blogs/cache/file/3165F741-DE77-47EF-A91AEDFD7E2F0CCA.jpg?w=590&amp;h=393&amp;6547259F-79F5-41F4-AB2C662797CFA768" alt="" /></picture><div class="article-media__object__btn-container"></div></div><figcaption class="article-media__caption t_caption"> <i>Credit: <a href="https://commons.wikimedia.org/wiki/File:Programming_language_textbooks.jpg">K.lee Wikimedia</a></i></figcaption></figure><figure class="aside-banner large-up-hide"><div id="dfp-right-article-mobile"><script>if (dfp.screen_size != "desktop"){dfp.load_dfp_ad("right", "right1", "dfp-right-article-mobile");}</script></div><figcaption class="aside-banner__label">Advertisement | <div class="pubnation" data-target="dfp-right-article-mobile" style="visibility: hidden;">Report Ad</div></figcaption></figure>			<div class="article-block article-text"><div class="mura-region">
					<div class="mura-region-local"><p>Programming has changed. In first generation languages like FORTRAN and C, the burden was on programmers to translate high-level concepts into code. With modern programming languages&mdash;I&rsquo;ll use Python as an example&mdash;we use functions, objects, modules, and libraries to extend the language, and that doesn&rsquo;t just make programs better, it changes what programming is.</p>

<p>Programming used to be about translation: expressing ideas in natural language, working with them in math notation, then writing flowcharts and pseudocode, and finally writing a program. Translation was necessary because each language offers different capabilities. Natural language is expressive and readable, pseudocode is more precise, math notation is concise, and code is executable.</p>

<p>But the price of translation is that we are limited to the subset of ideas we can express effectively in each language. Some ideas that are easy to express computationally are awkward to write in math notation, and the symbolic manipulations we do in math are impossible in most programming languages.</p>

<p>The power of modern programming languages is that they are expressive, readable, concise, precise, and executable. That means we can eliminate middleman languages and use one language to explore, learn, teach, and think.</p>

<figure class="image-captioned"><img alt="" height="696" src="/sciam/assets/File/bfs_pseudo(1).jpg" width="600" />
	<figcaption>Figure 1</figcaption>
</figure>

<p>As an example, Figure 1 shows the breadth first search (BFS) algorithm expressed in the pseudocode used in a popular textbook. The authors designed this language to be more concise and readable than most programming languages at the time, which was 1989.</p>

<p>Figure 2 shows the same algorithm in Python. It is a few lines shorter than the pseudocode, and because it uses more words than symbols, I think it&rsquo;s more readable. Also, unlike pseudocode, we can run it, display the results, and debug it.</p>

<figure class="image-captioned"><img alt="" height="377" src="/sciam/assets/File/bfs_python.jpg" width="600" />
	<figcaption>Figure 2</figcaption>
</figure>

<p>Running programs is the whole point of programming, of course, but there is more to it. The ability to execute code makes programming a tool for thinking and exploring. When we express ideas as programs, we make them testable; when we debug programs, we are also debugging our brains.</p>

<p>Languages like Python are also ideal for learning and teaching. For example, I wrote a book recently about digital signal processing (DSP). I used Python to write a simple library and Jupyter (which is a software development environment) to compose online notebooks that combine text, code, and results, including images and sound clips.</p>

<p>As I developed the book, I wrote code to test my understanding and explain it to students at the same time. Students can run the code to develop a mental model, make changes to test their predictions, and extend my code for their projects.</p>

<p>Most textbooks and classes use math to teach signal processing, with students working primarily with paper and pencil. With this approach, the only option is to go &ldquo;bottom up&rdquo;, starting with the arithmetic of complex numbers, which is not the most exciting topic, and taking weeks and many pages to get to relevant applications.</p>

<p>With a computational approach, we can go &ldquo;top down&rdquo;, starting with libraries that implement the most important algorithms, like Fast Fourier Transform. Students can use the algorithms first and learn how they work later. They can see the most important ideas, like spectral decomposition, without being blinded by details. They can work on real applications, on the first day, that provide the motivation to go deeper. And they can have a lot more fun.To demonstrate, I wrote a Jupyter notebook called &ldquo;<a href="https://nbviewer.jupyter.org/github/AllenDowney/ThinkDSP/blob/master/code/cacophony.ipynb">Cacophony for the whole family</a>.&rdquo; If you click that link, you can see the code and listen to the examples. It uses the library I wrote to simulate the sound of a grade school band, with instruments out of tune and some children randomly playing the wrong note. It&rsquo;s meant to be silly (and a little bit mean), but it also demonstrates aspects of how we perceive sound and interpret the pitch of a complex signal.</p>

<p>The languages I am calling modern are not particularly new; in fact, Python is more than 25 years old. But they are not yet widely taught in high schools and colleges. And even where they are adopted, they are often used in a style that does not take advantage of their power.</p>

<p>Modern programming languages are qualitatively different from their predecessors, but we are only beginning to realize the implications of that difference.</p>

<p><a href="http://allendowney.blogspot.com/2017/04/python-as-way-of-thinking.html">In a companion article, I present more ways to use Python to think, explore, learn, and teach.&nbsp;</a></p>

<p>&nbsp;</p></div>
					</div></div><section class="blog-disclaimer"><p>The views expressed are those of the author(s) and are not necessarily those of Scientific American. </p></section><section class="article-rightslink">
		
			
		
			<div class="article-reprintsLink">
				<span>
					
					
					<script>
						function RightsLinkPopUp() {
							
							
							var url = "https://s100.copyright.com/AppDispatchServlet";
							
							var location = url
								+ "?publisherName=" + encodeURI('sciam')
								+ "&publication=" + encodeURI('sciam')
								+ "&title=" + encodeURI('Programming as a Way of Thinking')
								+ "&publicationDate=" + encodeURI('2017-04-26')
								
								+ "&author=" + encodeURI('Allen Downey')
								
								+ "&contentID=" + encodeURI('07616940-7010-46B9-B4F730530E741A16')
								
								
								+ "&copyright=" + encodeURI('Copyright 2017 ')
								
								+ "&orderBeanReset=true";
							PopUp = window.open( location,'RightsLink','location=no,toolbar=no,directories=no,status=no,menubar=no,scrollbars=yes,resizable=yes,width=650,height=550');
							return false;
						}
					</script>
					<a href="#" onClick="RightsLinkPopUp(); return false;" class="rightsPermissions">
						<img src="/sciam/includes/themes/responsive/images/global/rightsPermsIcon.png"> Rights &amp; Permissions
					</a>
				</span>
			</div>
		

		
		</section><figure class="aside-banner aside-banner__article-bottom"><div id="dfp-right2-article"><script>dfp.load_dfp_ad("right2", "right2", "dfp-right2-article");</script></div><figcaption class="aside-banner__label">Advertisement | <div class="pubnation" data-target="dfp-right2-article" style="visibility: hidden;">Report Ad</div></figcaption></figure><section class="article-author-container"><h3 class="article-author-container__title">ABOUT THE AUTHOR(S)</h3><section class="article-author"><div class="article-author__main"><p class="article-author__name t_body t_body--article">Allen Downey</p><ul class="article-author__social"></ul><p class="article-author__desc t_body t_body--article">Allen Downey is a Professor of Computer Science at Olin College in Needham MA. He is the author of "Think Python," "Think DSP" and other books that use Python to explore topics in engineering and data science.</p></div></section></section></section><aside class="article-grid__aux"><figure class="aside-banner small-hide medium-hide"><div id="dfp-right-article"><script>if (dfp.screen_size == "desktop"){dfp.load_dfp_ad("right", "right1", "dfp-right-article");}</script></div><figcaption class="aside-banner__label">Advertisement | <div class="pubnation" data-target="dfp-right-article" style="visibility: hidden;">Report Ad</div></figcaption></figure><section class="aside-block" id="read-next"><h2 class="aside-block__title"><span>Latest News</span></h2><div class="aside-block__body"><div class="related-article-group"><div class="related-article-group__item"><a href="https://www.scientificamerican.com/article/learning-how-to-be-a-human-bat/" class="large-up-title-link"><section class="related-article"><div class="related-article__thumb"><div class="t_tag related-article__thumb__category">Cognition</div><picture><source media="(min-width: 768px) and (max-width: 1023px)" srcset="/sciam/cache/file/28F526F9-20BC-49D0-8E00B0FFE74E63A7_agenda.jpg?w=330&amp;h=220"><source media="(max-width: 767px)" srcset="/sciam/cache/file/28F526F9-20BC-49D0-8E00B0FFE74E63A7_small.jpg"><img src="/sciam/cache/file/28F526F9-20BC-49D0-8E00B0FFE74E63A7_medium.jpg?w=170&amp;h=113" alt="Learning How to Be a Human Bat"></picture></div><div class="related-article__body"><h3 class="related-article__title">Learning How to Be a Human Bat</h3><p class="related-article__meta">1 hour ago  —  Lore Thaler and Liam Norman</p></div></section></a></div><div class="related-article-group__item"><a href="https://www.scientificamerican.com/article/parents-tinker-with-kids-rsquo-diet-to-treat-adhd/" class="large-up-title-link"><section class="related-article"><div class="related-article__thumb"><div class="t_tag related-article__thumb__category">Behavior &amp; Society</div><picture><source media="(min-width: 768px) and (max-width: 1023px)" srcset="/sciam/cache/file/A09FBED9-7F00-45FE-BB7197735230085B_agenda.jpg?w=330&amp;h=220"><source media="(max-width: 767px)" srcset="/sciam/cache/file/A09FBED9-7F00-45FE-BB7197735230085B_small.jpg"><img src="/sciam/cache/file/A09FBED9-7F00-45FE-BB7197735230085B_medium.jpg?w=170&amp;h=113" alt="Parents Tinker With Kids' Diet to Treat ADHD"></picture></div><div class="related-article__body"><h3 class="related-article__title">Parents Tinker With Kids' Diet to Treat ADHD</h3><p class="related-article__meta">1 hour ago  —  Colleen Kimmett and STAT</p></div></section></a></div><div class="related-article-group__item"><a href="https://www.scientificamerican.com/article/science-wins-reprieve-in-u-s-budget-deal/" class="large-up-title-link"><section class="related-article"><div class="related-article__thumb"><div class="t_tag related-article__thumb__category">Policy &amp; Ethics</div><picture><source media="(min-width: 768px) and (max-width: 1023px)" srcset="/sciam/cache/file/EDE3856B-50E7-4306-AAA0753A844FD756_agenda.jpg?w=330&amp;h=220"><source media="(max-width: 767px)" srcset="/sciam/cache/file/EDE3856B-50E7-4306-AAA0753A844FD756_small.jpg"><img src="/sciam/cache/file/EDE3856B-50E7-4306-AAA0753A844FD756_medium.jpg?w=170&amp;h=113" alt="Science Wins Reprieve in U.S. Budget Deal"></picture></div><div class="related-article__body"><h3 class="related-article__title">Science Wins Reprieve in U.S. Budget Deal</h3><p class="related-article__meta">1 hour ago  —  Sara Reardon, Erin Ross and Nature magazine</p></div></section></a></div><div class="related-article-group__item"><a href="https://www.scientificamerican.com/article/the-cultural-fault-line-that-is-reshaping-global-politics/" class="large-up-title-link"><section class="related-article"><div class="related-article__thumb"><div class="t_tag related-article__thumb__category">Policy &amp; Ethics</div><picture><source media="(min-width: 768px) and (max-width: 1023px)" srcset="/sciam/cache/file/106B2A65-72C9-437E-899255CD9F833F9C_agenda.jpg?w=330&amp;h=220"><source media="(max-width: 767px)" srcset="/sciam/cache/file/106B2A65-72C9-437E-899255CD9F833F9C_small.jpg"><img src="/sciam/cache/file/106B2A65-72C9-437E-899255CD9F833F9C_medium.jpg?w=170&amp;h=113" alt="The Cultural Fault-Line that Is Reshaping Global Politics"></picture></div><div class="related-article__body"><h3 class="related-article__title">The Cultural Fault-Line that Is Reshaping Global Politics</h3><p class="related-article__meta">2 hours ago  —  Michele Gelfand, Joshua Conrad Jackson, Jesse R. Harrington and The Conversation US</p></div></section></a></div><div class="related-article-group__item"><a href="https://blogs.scientificamerican.com/sa-visual/interactive-brain-art/" class="large-up-title-link"><section class="related-article"><div class="related-article__thumb"><div class="t_tag related-article__thumb__category">Neuroscience</div><picture><source media="(min-width: 768px) and (max-width: 1023px)" srcset="/blogs/cache/file/C8885BB0-1264-4328-8003A78258AC3129_agenda.png?w=330&amp;h=220"><source media="(max-width: 767px)" srcset="/blogs/cache/file/C8885BB0-1264-4328-8003A78258AC3129_small.png"><img src="/blogs/cache/file/C8885BB0-1264-4328-8003A78258AC3129_medium.png?w=170&amp;h=113" alt="Interactive Brain Art"></picture></div><div class="related-article__body"><h3 class="related-article__title">Interactive Brain Art</h3><p class="related-article__meta">May 2, 2017  —  Jen Christiansen</p></div></section></a></div><div class="related-article-group__item"><a href="https://www.scientificamerican.com/article/the-art-and-science-of-making-movies-moves-to-the-outdoors-1917/" class="large-up-title-link"><section class="related-article"><div class="related-article__thumb"><div class="t_tag related-article__thumb__category">Arts &amp; Culture</div><picture><source media="(min-width: 768px) and (max-width: 1023px)" srcset="/sciam/cache/file/75029CCE-9166-4E51-B299B3D62622C240_agenda.jpg?w=330&amp;h=220"><source media="(max-width: 767px)" srcset="/sciam/cache/file/75029CCE-9166-4E51-B299B3D62622C240_small.jpg"><img src="/sciam/cache/file/75029CCE-9166-4E51-B299B3D62622C240_medium.jpg?w=170&amp;h=113" alt="The Art and Science of Making Movies Moves to the Outdoors, 1917"></picture></div><div class="related-article__body"><h3 class="related-article__title">The Art and Science of Making Movies Moves to the Outdoors, 1917</h3><p class="related-article__meta">3 hours ago  —  Daniel C. Schlenoff</p></div></section></a></div></div></div></section><div class="mura-region"><div class="mura-region-inherited"></div><div class="mura-region-local"></div></div></aside></div></div></div><figure class="footer-banner small-hide" data-footer-banner><div id="dfp-middle-footer"><script>if (dfp.screen_size != "mobile"){dfp.load_dfp_ad("middle", "bottom", "dfp-middle-footer");}</script></div><div class="pubnation" data-target="dfp-middle-footer" style="visibility: hidden;">Report Ad</div></figure><section class="container newsletter-subscribe-container"><h2 class="hr-titles"><span>Newsletter</span></h2><div class="newsletter-subscribe"><h2 class="newsletter-subscribe__title">Get smart. Sign up for our email newsletter.</h2><div class="newsletter-subscribe__inner"><a href="https://www.scientificamerican.com/page/newsletter-sign-up/?origincode=2016_blogs_ArticleFooter_NewsletterSignUp&category=&WT.ac=SA_Article_Footer_NewsletterSubscribe&wtaction=SA_SubmitForm_NewsletterSubscribe" class="btn">Sign Up</a></div></div></section><div class="mobile-context-nav" data-behavior="mobile_context_nav"><a href="#" class="mobile-context-nav__back"><span class="icon icon__uparr--black icon--subtle"></span></a><ul class="mobile-context-nav__nav tooltip-outer"><li><a href="#" data-mobile-context-nav-tab="share">Share</a></li><li><a href="#" data-mobile-context-nav-tab="latest">Latest</a></li></ul><div class="mobile-context-nav__body mobile-context-nav__body--share"><ul class="mobile-context-share"><li><a href="https://m.facebook.com/sharer.php?u=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/?wt.mc=SA_Facebook-Share"><span class="icon icon icon--subtle icon__facebook--white"></span></a></li><li><a href="https://twitter.com/intent/tweet?url=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/?wt.mc=SA_Twitter-Share&amp;text=Programming as a Way of Thinking&amp;hashtags=science"><span class="icon icon icon--subtle icon__twitter--white"></span></a></li><li><a href="http://www.reddit.com/submit?url=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/%3Fwt.mc=SA_Reddit-Share"><span class="icon icon icon--subtle icon__reddit--white"></span></a></li><li><a href="https://plus.google.com/share?url=https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/?wt.mc=SA_GPlus-Share"><span class="icon icon icon--subtle icon__googleplus--white"></span></a></li><li><a href="https://blogs.scientificamerican.com/email-this-article/?contentid=07616940-7010-46B9-B4F730530E741A16"><span class="icon icon icon--subtle icon__mail--white"></span></a></li></ul></div><div class="mura-async-object" data-object="mobile-persistent-nav" data-instanceid="0" data-siteid="blogs" data-contentid="00000000000000000000000000000000001" data-contenthistid=""></div></div><div class="container" data-blog-next-previous><h2 class="hr-titles"><span>Read More</span></h2><section class="grid"><div class="grid__col large-up-1-2"><div class="article-next article-next--prev hit"><div class="article-next__label">Previous</div><h3 class="article-next__title"><span class="underline">Post-Science March, We Must Stay Engaged</span></h3><ul class="meta-list t_meta article-next__meta"><li class="meta-list__item">By Sheril Kirshenbaum on April 25, 2017</li></ul><a href="https://blogs.scientificamerican.com/guest-blog/post-science-march-we-must-stay-engaged/" class="hit__link"></a></div></div><div class="grid__col large-up-1-2"><div class="article-next article-next--next hit"><div class="article-next__label">Next</div><h3 class="article-next__title"><span class="underline">The Perils of Public Outreach</span></h3><ul class="meta-list t_meta article-next__meta"><li class="meta-list__item">By Julia Shaw on April 26, 2017</li></ul><a href="https://blogs.scientificamerican.com/guest-blog/the-perils-of-public-outreach/" class="hit__link"></a></div></div></section></div><aside class="tout_subscribe container"><h2 class="tout_subscribe-title">Every Issue. Every Year. 1845 - Present</h2><p class="small-hide">Neuroscience. Evolution. Health. Chemistry. Physics. Technology.</p><a href="http://www.scientificamerican.com/store/subscribe/scientific-american-magazine/?WT.ac=SA_ecom_SA_FooterPromo" class="btn editable-button">Subscribe Now!</a><picture><source media="(max-width: 767px)" srcset="/sciam/cache/file/E82AEBA1-0A06-4B0F-9B1CFF1CE6BD8745_source.png?w=220&amp;h=100" /><source media="(min-width: 768px) and (max-width: 1023px)" srcset="/sciam/cache/file/E82AEBA1-0A06-4B0F-9B1CFF1CE6BD8745_source.png?w=420&amp;h=190" /><img src="/sciam/cache/file/BD1A6893-C362-486B-B0FBB38C1A104C46_source.png?w=385&amp;h=375" alt="Every Issue. Every Year. 1845 - Present" /></picture></aside></div></main></div></div><div class="footer-outer"><footer id="footer" class="container"><p></p><div class="panel"><div class="grid"><div class="col grid__col grid__col--first">
	<ul class="footer-links">
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/store/">Store</a></li>
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/about-scientific-american/">About</a></li>
		<li class="footer-links__item t_meta">
 <a href="http://www.scientificamerican.com/pressroom/">Press Room</a>
 </li>
		<li class="footer-links__item large-up-hide" data-footer-reveal-parent=""><a data-behavior="footer_reveal" href="#">More </a></li>
	</ul>
</div>

<div class="grid__col small-first-col medium-down-hide">
	<ul class="footer-links">
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/frequently-asked-questions/">FAQs</a></li>
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/contact-us/">Contact Us</a></li>
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/sitemap">Site Map</a></li>
	</ul>
</div>

<div class="grid__col medium-first-col small-first-col medium-down-hide">
	<ul class="footer-links">
		<li class="footer-links__item t_meta"><a href="http://www.scientificamerican.com/mediakit/">Advertise</a></li>
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/ad-sections/">Special Ad Sections</a></li>
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/custom-media-and-partnerships/">SA Custom Media</a></li>
	</ul>
</div>

<div class="grid__col small-first-col medium-down-hide">
	<ul class="footer-links">
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/terms-of-use/">Terms of Use</a></li>
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/privacy-policy/">Privacy Policy</a></li>
		<li class="footer-links__item t_meta"><a href="https://www.scientificamerican.com/page/use-of-cookies/">Use of Cookies</a></li>
	</ul>
</div></div></div><div class="panel"><div class="tx_meta footer_disclosure">Scientific American is part of Springer Nature, which owns or has commercial relations with thousands of scientific publications (many of them can be found at <a href="http://www.springernature.com/us" target="_blank">www.springernature.com/us</a>). Scientific American maintains a strict policy of editorial independence in reporting developments in science to our readers.</div><small><em>&copy; 2017 Scientific American, a Division of Nature America, Inc.<br /><br />All Rights Reserved.</em></small></div></footer></div><div class="wt-track-wrap" data-behavior="wt_tracking"></div><noscript><img alt="dcsimg" id="dcsimg" width="1" height="1" src="//statse.webtrendslive.com/dcszbiart00000oiar2s6w5ud_4y9j/njs.gif?dcsuri=/nojavascript&amp;WT.js=No&amp;WT.tv=10.4.12&amp;dcssip=www.sciam.com"/></noscript><section class="global__toaster-ad" id="global__toaster-ad" data-behavior="toaster"><span class="icon icon__close--white global__toaster-ad__close" id="global__toaster-ad__close"></span><div class="global__toaster-ad__inner-wrap"><h3>NEW eBook!</h3><div class="global__toaster-ad__left"><img src="/sciam/cache/file/890E112D-E0D6-401E-BC052AC2F1080E69_source.png"></div><div class="global__toaster-ad__right"><p><p>
	<style type="text/css"><!--td {border: 1px solid #ccc;}br {mso-data-placement:same-cell;}--></style>
	Get the latest on Alzheimer&rsquo;s and more</p></p><div class="btn btn--small btn--inverted editable-button editable-button--toaster"><a href="https://www.scientificamerican.com/store/books/fragile-brain-neurodegenerative-diseases/?WT.mc_id=SA_ebook_FragileBrain_toaster-ad&amp;utm_source=promotion&amp;utm_medium=toaster-ad&amp;utm_campaign=eBook_FragileBrain">Buy Now</a></div></div></div></section>		
<script>WT={"sa_cstatus_registrant":"0","sa_access_status":"","sa_cstatus_customer":"0","sa_cattop":"","sa_cat":"","doi":"","sa_authors":"Allen Downey","sa_article_id":"","dcssip":"www.sciam.com","cg_s":"Blog: Guest Blog","sa_cstatus_subscriber":"0","z_cg_ecollection":"","z_css":"desktop","cg_n":"Scientific American Blog Network","sa_cstatus_sitelicense":"0","sa_issue":"","sa_pubdate":"2017/04/26","css":""};</script>
<!-- START Parse.ly Include: Standard -->
	<div id="parsely-root" style="display: none">
		<div id="parsely-cfg" data-parsely-site="scientificamerican.com"></div>
	</div>
	<script>
		(function(s, p, d) {
		 var h=d.location.protocol, i=p+"-"+s,
		 e=d.getElementById(i), r=d.getElementById(p+"-root"),
		 u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
		 :"static."+p+".com";
		 if (e) return;
		 e = d.createElement(s); e.id = i; e.async = true;
		 e.src = h+"//"+u+"/p.js"; r.appendChild(e);
		})("script", "parsely", document);
	</script>
	<!-- END Parse.ly Include -->
	
		
 

 
		
		
		
		<script type="application/ld+json" id="datablock0">
			{"thumbnailUrl":"https://blogs.scientificamerican.com/blogs/cache/file/3165F741-DE77-47EF-A91AEDFD7E2F0CCA_small.jpg","keywords":["Tech","Computing","blogs"],"creator":["Allen Downey"],"@context":"http://schema.org","@type":"NewsArticle","headline":"Programming as a Way of Thinking","articleSection":"Blog: Guest Blog","url":"https://blogs.scientificamerican.com/guest-blog/programming-as-a-way-of-thinking/","dateCreated":"2017-04-18T12:00:08Z-0400"}
		</script>
<script type="text/javascript" src="//nexus.ensighten.com/npg/prod-sa/Bootstrap.js"></script><script src="/public/resources/main-564d3d638ff7f7003257d86e53c4e324.js"></script><noscript><div><img src="//secure-us.imrworldwide.com/cgi-bin/m?ci=us-403331h&amp;cg=0&amp;cc=1&amp;ts=noscript" width="1" height="1" alt="" /></div></noscript></body></html>